赢顺k线原公式,SV决策图主图公式 大智慧指标源码贴图决策

SV决策图主图公式 大智慧指标源码贴图决策详细说明

      SV决策图主图


     SV决策图


     TODAY:="ddx.ddx"=0;{判断是否有正版数据}
TODAY1:=DYNAINFO(7)=CLOSE and DYNAINFO(10)=AMOUNT and (ORDER(1)=0 and ORDER(2)=0);
Ddmr:=IF(TODAY,("[email protected]"(1,2)-"[email protected]"(2,2)),(bigorder(1,2)-bigorder(2,2)));
Ddmrs:=sum(Ddmr,0);
{CY}
主单买:=IF(TODAY,IF(TODAY1,"[email protected]"(1,2),SELFDATA('特大买入')+SELFDATA('大单买入')),bigorder(1,2))*V/CAPITAL;
主单卖:=IF(TODAY,IF(TODAY1,"[email protected]"(2,2),SELFDATA('特大卖出')+SELFDATA('大单卖出')),bigorder(2,2))*V/CAPITAL;
特单买:=IF(TODAY,IF(TODAY1,"[email protected]"(1,3),SELFDATA('特大买入')),bigorder(1,3))*V/CAPITAL;
特单卖:=IF(TODAY,IF(TODAY1,"[email protected]"(2,3),SELFDATA('特大卖出')),bigorder(2,3))*V/CAPITAL;
大单买:=IF(TODAY,IF(TODAY1,("[email protected]"(1,2)-"[email protected]"(1,3)),SELFDATA('大单买入')),(bigorder(1,2)-bigorder(1,3)))*V/CAPITAL;
大单卖:=IF(TODAY,IF(TODAY1,("[email protected]"(2,2)-"[email protected]"(2,3)),SELFDATA('大单卖出')),(bigorder(2,2)-bigorder(2,3)))*V/CAPITAL;
中单买:=IF(TODAY,IF(TODAY1,("[email protected]"(1,1)-"[email protected]"(1,2)),SELFDATA('中单买入')),(bigorder(1,1)-bigorder(1,2)))*V/CAPITAL;
中单卖:=IF(TODAY,IF(TODAY1,("[email protected]"(2,1)-"[email protected]"(2,2)),SELFDATA('中单卖出')),(bigorder(2,1)-bigorder(2,2)))*V/CAPITAL;
小单买:=IF(TODAY,IF(TODAY1,1-("[email protected]"(1,1)),1-(SELFDATA('特大买入')+SELFDATA('大单买入')+SELFDATA('中单买入'))),1-(bigorder(1,1)))*V/CAPITAL;
小单卖:=IF(TODAY,IF(TODAY1,1-("[email protected]"(2,1)),1-(SELFDATA('特大卖出')+SELFDATA('大单卖出')+SELFDATA('中单卖出'))),1曾涨停指标公式源码-(bigorder(2,1)))*V/CAPITAL;
MA157:eMA(CLOSE,157),colorFF7676;
MA5:eMA(CLOSE,5),COLORFFAA66;
MA11:eMA(CLOSE,11),COLORFFFFCC;
MA24:eMA(CLOSE,24),Color9DFFFF;
MA38:eMA(CLOSE,38),ColorABFF46;
MA55:eMA(CLOSE,55),Color8000FF;
MA96:MA(CLOSE,96),POINTDOT,linethick4,colorYellow;
MA191:eMA(CLOSE,191),Colorffffff;
MA262:eMA(CLOSE,262),colorfaabec;
MA314:eMA(CLOSE,314),color00ff00;
MA453:eMA(CLOSE,453),colorCyan;
DRAWGBK(c,'7' );
Var3:=LLV(H,240);
Var4:=100*(C-Var3)/Var3;
Var5:=(C-LLV(L,528))/(HHV(H,528)-LLV(L,528))*100;
Var6:=(C-LLV(C,530))/(HHV(C,530)-LLV(C,530))*100;
Var7:=0;
Var8:=MA(HHV(C-REF(C,1),0),34)/MA(ABS(C-REF(C,1)),7)*100;
Var9:=MA(HHV(C-REF(C,1),0),13)/MA(ABS(C-REF(C,1)),13)*100;
VarA:=BARSCOUNT(C);
VarB:=Var8<20 AND Var9<23 AND VarA>35;
VarC:=VarB AND COUNT(VarB,1)=1;
VarD:=EMA(C,21)-EMA(C,8);
VarE:=EMA(VarD,5);
VarF:=TROUGH(3,6,1)<4 AND CROSS(VarD,VarE);
Var10:=IF(TROUGH(3,16,1)=0 AND H>L+0.04,4,0);
Var11:=ZIG(3,6)>REF(ZIG(3,6),1) AND REF(ZIG(3,6),1)<=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)<=REF(ZIG(3,6),3);
Var12:=ZIG(3,6)<REF(ZIG(3,6),1)AND REF(ZIG(3,6),1)>=REF(ZIG(3,6),2) AND REF(ZIG(3,6),2)>=REF(ZIG(3,6),3);
Var13:=ZIG(3,22)>REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)<=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)<=REF(ZIG(3,22),3);
Var14:=ZIG(3,22)<REF(ZIG(3,22),1)AND REF(ZIG(3,22),1)>=REF(ZIG(3,22),2)AND REF(ZIG(3,22),2)>=REF(ZIG(3,22),3);
Var15:=ZIG(3,51)>REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)<=REF(ZIG(3,51),2) AND REF(ZIG(3,51),2)<=REF(ZIG(3,51),3);
Var16:=ZIG(3,51)<REF(ZIG(3,51),1)AND REF(ZIG(3,51),1)>=REF(ZIG(3,51),2)AND REF(ZIG(3,51),2)>=REF(ZIG(3,51),3);
Var17:=ZIG(3,72)>REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)<=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)<=REF(ZIG(3,72),3);
Var18:=ZIG(3,72)<REF(ZIG(3,72),1) AND REF(ZIG(3,72),1)>=REF(ZIG(3,72),2)AND REF(ZIG(3,72),2)>=REF(ZIG(3,72),3);
Var19:=EMA(C,2)-EMA(C,150);
Var1A:=EMA(Var19,100);
Var1B:=2*(Var19-Var1A);
Var1C:=POW(Var1B,3)*0.1+POW(Var1B,1);
Var1D:=SQRT(SQRT(L*H*O*C));
Var1E:=EMA(Var1D*0.97,3);
Var1F:=(H+L+C)/3;
Var20:=(Var1F-MA(Var1F,14))/(0.015*AVEDEV(Var1F,14));
Var21:=CROSS(Var1E,L);
买点1:=Var10;
买点2:=(Var11+Var13+Var15+Var17);
卖点1:=(Var12+Var14+Var16+Var18);
Var22:=买点1 AND VarF AND VarC AND Var21 AND Var4<0AND Var5=0 AND Var6=0 AND Var20<(-110);
DRAWTEXT(买点1>0,L-0.15,'多'),LINETHICK2,ALIGN1,colorred;
DRAWTEXT(买点2>0,L-0.15,'多'),LINETHICK2,ALIGN1,ColorRed;
DRAWTEXT(卖点1>0,H+0.35,'空'),LINETHICK2,ALIGN1,COLOR33FF33;


     x1:=(C+L+H)/3;
x2:=EMA(x1,6);
x3:=EMA(x2,5);
DRAWICON(CROSS(X2,X3),L-0.1,10);
DRAWICON(CROSS(X3,X2),H+0.1,12);
stickline(x2>=x3,low,high,0.1,1),colorred;
stickline(x2>=x3,close,open,9,2),colorred;
stickline(x2>=x3,close,open,9,8);
stickline(x2<x3,low,high,0.1,1),colorGREEN;
stickline(x2<x3,close,open,9,2),colorGREEN;
stickline(CROSS(X2,X3),open,close,6,1),colorYELLOW;
stickline(CROSS(X3,X2),open,close,6,1),colorBLUE;


     a:="[email protected]";
s1:="[email protected]_S1";
hs:="[email protected]_HS";
ls:="[email protected]_LS";
p1:="[email protected]_P1";
upp:="[email protected]_UPP";
udd:="[email protected]_UDD";
{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};
买入:p1=1 and ref(p1,1)=0,LineThick0,Precis0,ColorRed;
d1:=ema(abs("lxddx.ddx"),60);
d2:=max("lxddx.ddx"/d1+7.5,7.5);
d3:=min("lxddx.ddx"/d1,10);
fb:=if(s1=0,hs,ls);
tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点\n','若明日收盘价>'+numtostrn(upp,2)+',出现B点\n');
tr1:=ifs(s1=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');
tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币'));
tr3:=ifs(s1=0,'向下,','向上,');
tr4:='3.能量级别:'+numtostrn(d3,1)+'级';
bs:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+datestr(date)+'买卖点决策系统提示\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'1.BS点:'+tr2+','+tr0+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'2.短线:'+tr3+tr1+'\n'+'<*t=E7FFFF*><*c=000000*>通达信 if选股公式怎么用;<*p=95*>'+tr4;
{drawflagtext(1,fb,bs);}
STICKLINE(p1=1 and c>=o and o<>0,c,o,d2,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,c,o,7.5,0),colorblack;
STICKLINE(p1=1 and c>=o and o<>0,c,c,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,o,7.5,0),color5454ff;
STICKLINE(p1=1 and c>=o and o<>0,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,o,c,7.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,l,c,0.5,1),color5454ff;
STICKLINE(p1=1 and c<=o,h,o,0.5,1),color5454ff;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,o,7.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,c,h,0.5,1),colorffff54;
STICKLINE((p1<>1 or barscount(c)<3) and c>=o,l,o,0.5,1),colorffff54;
drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;
drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;
drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0;
drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2;
HS:=vol/capital;
机构净买:=(特单买-特单卖)*100;
机构总买:=sum(机构净买,7);
大户净买:=(大单买-大单卖)*100;
大户总买:=sum(大户净买,7);
中户净买:=(中单买-中单卖)*100;
中户总买:=sum(中户净买,7);
散户净买:=(小单买-小单卖)*100;
散户总买:=sum(散户净买,7);
主力净买:=(主单买-主单卖)*100;
主力总买:=sum(主力净买,7);
帐户数:extradata('散户线'),linethick0,PRECIS0;
户均持股:=(FINANCE2(37)/帐户数)*10000;
SH:=sum(散户净买,7);
ZH:=sum(中户净买,7);
DH:=sum(大户净买,7);
TD:=sum(机构净买,7);
{量帐号柱}
sgl:=7;
DRAWRECTABS(90 ,30 ,150 ,40,0 ),ColorD4D4D通達信海洋寻底选股公式4;
DRAWRECTABS(90 ,50 ,150 ,60,0 ),ColorD4D4D4;
DRAWRECTABS(90 ,70 ,150 ,80 ,0 ),ColorD4D4D4;
DRAWRECTABS(90 ,90,150 ,100 ,0 ),ColorD4D4D4;
DRAWTEXTABS(10 ,10 ,'分类持仓' ),colorwhite;
DRAWTEXTABS(90 ,10 ,numtostrn(sgl,0)+'日持仓' ),colorwhite;
DRAWTEXTABS(10 ,30 ,'机构持仓' ),colorwhite;
DRAWTEXTABS(10 ,50 ,'大户持仓' ),colorwhite;
DRAWTEXTABS(10 ,70 ,'中户持仓' ),colorwhite;
DRAWTEXTABS(10 ,90 ,'散户持仓' ),colorwhite;
DRAWRECTABS( 90,30 ,120+ref(机构总买*10,1) ,40 ,0 ),ColorFF2E40;
DRAWRECTABS( 90,50 ,120+ref(大户总买*10,1) ,60 ,0 ),ColorFF2E40;
DRAWRECTABS( 90,70 ,120+ref(中户总买*10,1),80 ,0 ),ColorFF2E40;
DRAWRECTABS( 90,90,120+ref(散户总买*10,1),100 ,0 ),ColorFF2E40;
DRAWRECTABS( 90,30 ,120+ref(机构总买*10,1)+机构净买*10 ,40 ,rgb(255,0,0) ),colorwhite;
DRAWRECTABS( 90,50 ,120+ref(大户总买*10,1)+大户净买*10 ,60 ,rgb(255,0,0) ),colorwhite;
DRAWRECTABS( 90,70 ,120+ref(中户总买*10,1)+中户净买*10,80 ,rgb(255,0,0) ),colorwhite;
DRAWRECTABS( 90,90,120+ref(散户总买*10,1)+散户净买*10,100 ,rgb(255,0,0) ),colorwhite;
DRAWTEXTABS(180 ,30 ,numtostrn(sgl,0)+'日增减'+numtostrn(机构总买,2)+'%' ),colorwhite;
DRAWTEXTABS(180 ,50 ,numtostrn(sgl,0)+'日增减'+numtostrn(大户总买,2)+'%' ),colorwhite;
DRAWTEXTABS(180 ,70, numtostrn(sgl,0)+'日增减'+numtostrn(中户总买,2)+'%' ),colorwhite;
DRAWTEXTABS(180 ,90 ,numtostrn(sgl,0)+'日增减'+numtostrn(散户总买,2)+'%' ),colorwhite;
DRAWTEXTABS(180 ,10 ,'帐户总数:'+numtostrn(帐户数,0)+'户 户均持股:'+numtostrn(户均持股,0)+'股'),colorwhite;


     



上一篇:通达信神奇均线选股指标公式,通达信纯K黄金分割主图指标公式

下一篇:底部红三兵选股公式怎么制作,通达信智能操盘指标公式

相关推荐