波段阶入点指标公式,无敌均线主图卫东老师作品公式 大智慧指标源码无敌源码

无敌均线主图卫东老师作品公式 大智慧指标源码无敌源码详细说明

      无敌均线主图卫东老师作品


     无敌均线


     INPUT:N1(5,0,999),N2(10,0,999),N3(20,0,999),N4(30,0,999),N5(60,0,999),N6(120,0,999),N日(8,1,20),K线(2,1,9);
MA1:MA(CLOSE,N1);
MA2:MA(CLOSE,N2);
MA3:MA(CLOSE,N3);
MA4:M倍量柱选股指标公式A(CLOSE,N4);
MA5:MA(CLOSE,N5);
MA6:MA(CLOSE,N6);
连红:LAST(CLOSE>OPEN),PRECIS0,color0000FF,linethick0;
连绿:LAST(CLOSE<OPEN),PRECIS0,color00FF00,linethick0;
x9:FORCAST(c,9),Colorwhite,LINETHICK2;
llx:=llv(FORCAST(c,9),2);
PARTLINE(x9,x9=llx,rgb(255,205,0),x9<>llx,rgb(255,0,0)),linethick2;
{13}
STICKLINE(CLOSE>OPEN,OPEN,LOW,1,0 ),COLOR0022FF; {收盘价>开盘价,从开盘价到最低价用红色}
STICKLINE(CLOSE>OPEN,CLOSE,HIGH,1 ,0 ),COLOR0022FF;{收盘价>开盘价,从收盘价到最高价用红色}
{16}
STICKLINE(CLOSE<=OPEN,CLOSE,LOW,1 ,0 ),Color00E100;{收盘价<=开盘价,从收盘价到最低价用绿色}
STICKLINE(CLOSE<=OPEN,OPEN,HIGH,1 ,0 ),Color00E100;{收盘价<=开盘价,从开盘价到最高价用绿色}
{19}
STICKLINE(CLOSE<=OPEN ,CLOSE ,OPEN,7.5,0 ),color003300;{收盘价&l金木水火土技术指标公式t;=开盘价,从收盘价到开盘价用绿色}
STICKLINE(CLOSE<=OPEN ,CLOSE ,OPEN,6,0 ),color005500;
STICKLINE(CLOSE<=OPEN ,CLOSE ,OPEN,5,0 ),color007700;
STICKLINE(CLOSE<=OPEN ,CLOSE ,OPEN,4,0 ),color009900;
STICKLINE(CLOSE<=OPEN ,CLOSE ,OPEN,2.5,0 ),color00bb00;
STICKLINE(CLOSE<=OPEN ,CLOSE ,OPEN,1,0 ),Color00E100;
{26}
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,7.5,0) ,COLOR000033;{收盘价>开盘价,从开盘价到收盘价用红色}
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,6,0) ,COLOR000066;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,5,0) ,COLOR000088;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,4,0) ,COLOR0000BB;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,2.5,0) ,COLOR0000EE;
STICKLINE(CLOSE>OPEN,CLOSE,OPEN,1,0) ,COLOR0000ff;
{33}
var9Q:=c= hhv(c,4)and (ref(c,1)>=ref(c,2) or ref(c,1)>=ref(c,3)) or ref(c,1)=hhv(c,4) and close>=ref(c,2) or ref(c,2)=hhv(c,4) and ref(c,3)=llv(c,4) and c>=ref(c,1) or ref(c,3)=hhv(c,4) and c>=ref(c,1) and c>=ref(c,2);
STICKLINE(var9Q,c,(o+c)/2,7.5,0),color000033;{符合上述条件,从收盘价到中间用红色}
STICKLINE(var9Q,c,(o+c)/2,6,0),color000066;
STICKLINE(var9Q,c,(o+c)/2,5,0),color000088;
STICKLINE(var9Q,c,(o+c)/2,4,0),color0000BB;
STICKLINE(var9Q,c,(o+c)/2,2.5,0),color0000EE;
STICKLINE(var9Q,c,(o+c)/2,1,0),color0000FF;
{41}
varaQ:=c=hhv(c,4) and ref(c,1)=llv(c,4);
STICKLINE(varaQ,c,(o+c)/2,7.5,0),Color4D0099;{符合上述条件,从收盘价到中间用玫红色}
STICKLINE(varaQ,c,(o+c)/2,6,0),Color5F00BD;
STICKLINE(varaQ,c,(o+c)/2,5,0),Color6500CA;
STICKLINE(varaQ,c,(o+c)/2,4,0),Color7600EC;
STICKLINE(varaQ,c,(o+c)/2,2.5,0),Color9933FF;
STICKLINE(varaQ,c,(o+c)/2,1,0),ColorAD5BFF;
{49}
varbQ:=c=llv(c,4) and (ref(c,1)<ref(c,2) or ref(c,1)<ref(c,3)) or ref(c,1)=llv(c,4) and c<ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<>hhv(c,4) and c<ref(c,1) or ref(c,3)=llv(c,4) and c<ref(c,1) and c<ref(c,2);
STICKLINE(varbQ,c,(o+c)/2,7.5,0),color333333;{符合上述条件,从收盘价到中间用银色}
STICKLINE(varbQ,c,(o+c)/2,6,0),color666666;
STICKLINE(varbQ,c,(o+c)/2,5,0),color888888;
STICKLINE(varbQ,c,(o+c)/2,4,0),colorBBBBBB;
STICKLINE(varbQ,c,(o+c)/2,2.5,0),colorEEEEEE;
STICKLINE(varbQ,c,(o+c)/2,1,0),colorffffff;
{57}
varcQ:=ref(c,1)=llv(c,4) and c>=ref(c,2) or ref(c,2)=llv(c,4) and ref(c,1)<=ref(c,3) and ref(c,2)<ref(c,4) and c>=ref(c,1);
stickline(varcQ,o,(o+c)/2,7.5,0),COLOR8D0B00;{符合上述条件,从开盘价到中间用蓝色}
stickline(varcQ,o,(o+c)/2,6,0),COLORC70E00;
stickline(varcQ,o,(o+c)/2,5,0),COLORFA1C10;
stickline(varcQ,o,(o+c)/2,4,0),COLORFF6044;
stickline(varcQ,o,(o+c)/2,2.5,0),COLORF97C0D;
stickline(varcQ,o,(o+c)/2,1,0),COLORFBA960;
{65}
{昨天的收盘价=近4天的最高值,或者,今天的收盘价<前天的收盘价 或 前天的收盘价=近4天的最高值,或者,昨天的收盘价>3天前的收盘价 或 3天前的收盘价=近4天的最高值,
或者,昨天的收盘价>前天的收盘价,或者,前天的收盘价>=近4天的最高值,或者,今天的收盘价<昨天的收盘价}
vardQ:=ref(c,1)=hhv(c,4) and c<ref(c,2) or (ref(c,2)=hhv(c,4) and ref(c,1)>ref(c,3) or ref(c,3)=hhv(c,4) and ref(c,1)>ref(c,2)) and ref(c,2)>=ref(c,4) and c<ref(c,1);
stickline(vardQ,o,(o+c)/2,7.5,0),color003300;{符合上述条件,从开盘价到中间用绿色}
stickline(vardQ,o,(o+c)/2,6,0),color005500;
stickline(vardQ,o,(o+c)/2,5,0),color007700;
stickline(vardQ,o,(o+c)/2,4,0),color009900;
stickline(vardQ,o,(o+c)/2,2.5,0),color00bb00;
stickline(vardQ,o,(o+c)/2,1,0),Color00E100;
{75}
{十字光标提示}
a:="[email protected]";
s1:="[email protected]_S1";
hs:="[email protected]_HS";
ls:="[email protected]_LS";
p1:="[email protected]_P1";
upp:="[email protected]_UPP";
udd:="[email protected]_UDD";
{hs;ls;hhs;lls;us;ds;s1;p1;p0;upp;udd};
d1:=ema(abs("ddx.ddx"),60);
d2:=max("ddx.ddx"/d1+7.5,7.5);
d3:=min("ddx.ddx"/d1,10);
fb:=if(s1=0,hs,ls);
tr0:=ifs(p1=1,'明日收盘价<'+numtostrn(udd,2)+',出现S点\n','若明日收盘价>'+numtostrn(upp,2)+',出现B点\n');{1.BS点:}
tr1:=ifs(s1=1,'明日收盘价<'+numtostrn(ls,2)+',短线卖出机会','若明日收盘价>'+numtostrn(hs,2)+'短线买入机会');{2.短线:}
tr2:=ifs(p1=1,ifs(cross(p1,0),'B点','持股'),ifs(cross(1,p1),'S点','持币'));{1.BS点:}
tr3:=ifs(s1=0,'向下,','向上,');{2.短线:}
tr4:='3.能量级别:'+numtostrn(d3,1)+'级';{3.能量级别:}
{94}
drawbmp(p1=1 and ref(p1,1)=0,l,'buy1.bmp'),align1,valign0;
drawbmp(p1=0 and ref(p1,1)=1,h,'sell1.bmp'),align1,valign2;
{97}
drawbmp(s1=1 and ref(s1,1)=0 and (p1+ref(p1,1))<>1,l,'bs.bmp'),align1,valign0;
drawbmp(s1=0 and ref(s1,1)=1 and (p1+ref(p1,1))<>1,h,'ss.bmp'),align1,valign2;
{100}
RSV:=(CLOSE-LLV(LOW,N日))/(HHV(HIGH,N日)-LLV(LOW,N日))*100;
K:SMA(RSV,K线,1),LINETHICK0;
D:SMA(K,K线,1),LINETHICK0;
J:3*K-2*D,LINETHICK0;
{105}
买入:=IF((J-D),CROSS(J, K),0);
卖出:=IF((J-D),CROSS(D, K),0);
DRAWTEXT(买入>0,L-0.25,'买'),LINETHICK4,ALIGN1,COLOR00FFFF;
DRAWTEXT(卖出>0,H+0.45,'卖'),LINETHICK4,ALIGN1,COLOR33FF33;
{110}
bs:='<*t=0092F7*><*c=FFFFFF*><*p=95*>'+datestr(date)+'买卖点决策系统提示“B.S”\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'1.BS点:'+tr2+','+tr0+'<*t=E7FFFF*><*c=000000*><*p=95*>'+'2.短线:'+tr3+tr1+'\n'+'<*t=E7FFFF*><*c=000000*><*p=95*>'+tr4+'\n'+'<*t=006000*><*c=FFFFFF*><*p=95*>'+'卫东KDJ提示“买”“卖”,仅供对比参考';
drawflagtext(1,fb,bs);
{113}
DRAWTEXTREL(0,0,'日K线'),COLORYELLOW;
DRAWTEXTREL(600,975,'证券代码: '+STKLABEL+' 证券名称: '+STKNAME+''),ColorFFAA00;
DRAWTEXTABS(30,0,'《QQ:512764231制作》'),COLOR0000FF;
总股本:=FINANCE2(35) ;
流通股:=FINANCE2(37);
限售A股:=FINANCE2(41);
每股收益:=FINANCE2(3);
市盈率:=DYNAINFO(39);
每股公积金:=FINANCE2(7);
所属板块:=BKNAME;
DRAWTEXTABS(0,14, '所属板块: '+所属板块),Color888888{,COLORYELLOW};
DRAWTEXTABS(0,27,'每股收益: '+NUMTOSTRN(每股收益,3)+'元 利润增长:'+FINANCE2(10)+'% 市盈率:'+NUMTOSTRN(市盈率,1)+'倍 '+' 每股公积金:'+NUMTOSTRN(每股公积金,2)+'元'),Color888888{,COLORYELLOW};
DRAWTEXTABS(0,40,'总 股 本: '+NUMTOSTRN(总股本,2)+'万股'+' 流通A股:'+NUMTOSTRN(流通股,2)+'万股'+' 限售A股:'+NUMTOSTRN(限售A股,2)+'万股'),Color888888{,COLORYELLOW};


     

主图叠加指标
绘制收盘kdj负值选股公式源码价的MA1、MA2、MA3、MA4、MA5、MA6日移动平均线
P1、P2、P3、P4、P5、P6一般取5日、10日、20日、30日、60日、120日。
用法:葛氏八法则(参见说明书或联机帮助)
1.短期均线向上穿越长期均线,买入信号
2.短期均线向下跌破长期均线,卖出信号


     新增十字光标提示。



上一篇:通达信神奇均线选股指标公式,通达信纯K黄金分割主图指标公式

下一篇:全天不破均价线选股公式,短线牛股-笔数差上穿单数差出公式 大智慧指标源码牛股

相关推荐